sources/luafilesystem/PKGBUILD
author Anders Bergh <anders1@gmail.com>
Mon, 17 Dec 2007 05:30:04 +0100
changeset 4 946a11dbdb23
parent 1 c42d991ddcdb
child 11 664cc1efa89d
permissions -rw-r--r--
update the dmdirc-nightly date add x86_64 to luafilesystem remove *.old from the repos before rsyncing

# Contributor: Anders Bergh <anders1@gmail.com>
pkgname=luafilesystem
pkgver=1.3.0
pkgrel=2
pkgdesc="File System Library for the Lua Programming Language"
arch=(i686 x86_64)
url="http://www.keplerproject.org/luafilesystem/"
license=('custom')
depends=(lua)
source=(http://luaforge.net/frs/download.php/2679/$pkgname-$pkgver.tar.gz
        LICENSE
        luafilesystem-arch.patch)
md5sums=('5a5aa378d8cb3e68d5fe0609f373f59f'
         'beb2b58c4b5c2782304a5b0267a5651b'
         '6a8d0b411d2807853ab89e7de07da34f')

build() {
  mkdir -p $startdir/pkg/usr/share/licenses/$pkgname
  cp $startdir/src/LICENSE $startdir/pkg/usr/share/licenses/$pkgname

  cd "$startdir/src/$pkgname-$pkgver"
  patch -p1 < "$startdir/src/luafilesystem-arch.patch"

  ./configure
  make || return 1
  make DESTDIR="$startdir/pkg" install

}

# vim:set ts=2 sw=2 et: