sources/luafilesystem/PKGBUILD
author Anders Bergh <anders1@gmail.com>
Fri, 21 Dec 2007 09:29:05 +0100
changeset 11 664cc1efa89d
parent 4 946a11dbdb23
permissions -rw-r--r--
add gdc (but it's not really working) add llvm add dmd.conf to backup array in libphobos remove ./configure from luafilsystem

# Contributor: Anders Bergh <anders1@gmail.com>
pkgname=luafilesystem
pkgver=1.3.0
pkgrel=3
pkgdesc="File System Library for the Lua Programming Language"
arch=(i686 x86_64)
url="http://www.keplerproject.org/luafilesystem/"
license=('custom')
depends=(lua)
source=(http://luaforge.net/frs/download.php/2679/$pkgname-$pkgver.tar.gz
        LICENSE
        luafilesystem-arch.patch)
md5sums=('5a5aa378d8cb3e68d5fe0609f373f59f'
         'beb2b58c4b5c2782304a5b0267a5651b'
         '6a8d0b411d2807853ab89e7de07da34f')

build() {
  mkdir -p $startdir/pkg/usr/share/licenses/$pkgname
  cp $startdir/src/LICENSE $startdir/pkg/usr/share/licenses/$pkgname

  cd "$startdir/src/$pkgname-$pkgver"
  patch -p1 < "$startdir/src/luafilesystem-arch.patch"

  make || return 1
  make DESTDIR="$startdir/pkg" install

}

# vim:set ts=2 sw=2 et: