diff CMakeLists.txt @ 326:baaf74652f4c signals

treat const and non-const functions as separate
author eldar1@eldar1-laptop
date Wed, 30 Dec 2009 16:12:42 +0000
parents 8a0cf14e3419
children 96a75b1e5b26
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Dec 30 11:25:07 2009 +0000
+++ b/CMakeLists.txt	Wed Dec 30 16:12:42 2009 +0000
@@ -319,10 +319,10 @@
 	else(NOT is_founded)
 	      set(qtd_libs ${${package}_lib_param} ${qtd_libs})
 	endif(NOT is_founded)	
-    endforeach(package ${PACKAGES_tmp})
+    endforeach(package ${PACKAGES_tmp})
     add_d_program(${name} ${SOURCES_tmp} NO_DEPS_SOURCES ${res_sources} ${uic_sources}
 	DEPENDS ${res_sources} INCLUDES ${QTD_IMPORT_PATH} ${CMAKE_CURRENT_BINARY_DIR}
-	LIB_PATHS ${QTD_LIBRARIES_PATH} ${CMAKE_SOURCE_DIR}/lib LIBS ${qtd_libs})
+	LIB_PATHS ${QTD_LIBRARIES_PATH} ${CMAKE_SOURCE_DIR}/lib ${QT_LIBRARY_DIR} LIBS ${qtd_libs})
     ## TODO: Uncomment.
     #if(STRIP AND ${CMAKE_BUILD_TYPE} EQUAL "Release" AND CMAKE_HOST_UNIX) ##
     #	add_custom_command(TARGET example_${name} POST_BUILD COMMAND "${STRIP}" ARGS "${output}")
@@ -581,4 +581,4 @@
 
 set(SECOND_RUN 0 CACHE INTERNAL "")
 
-endif(NOT SECOND_RUN)
\ No newline at end of file
+endif(NOT SECOND_RUN)