diff generator/CMakeLists.txt @ 7:b8a79f9fba5a

More fixes and cleanups in CMake build script.
author SokoL_SD
date Thu, 14 May 2009 08:36:04 +0000
parents 0a29ce1ae854
children 16eec94c5b33
line wrap: on
line diff
--- a/generator/CMakeLists.txt	Wed May 13 23:40:31 2009 +0000
+++ b/generator/CMakeLists.txt	Thu May 14 08:36:04 2009 +0000
@@ -187,14 +187,6 @@
     set(gen_sources ${gen_sources} ${CMAKE_SOURCE_DIR}/generator/typesystem_${package}.xml)
 endforeach(package ${packages})
 
-MACRO(MAKE_WINDOWS_PATH pathname)
-    # An extra \\ escape is necessary to get a \ through CMake's processing.
-    STRING(REPLACE "/" "\\" ${pathname} "${${pathname}}")
-    # Enclose with UNESCAPED quotes.  This means we need to escape our
-    # quotes once here, i.e. with \"
-    SET(${pathname} \"${${pathname}}\")
-ENDMACRO(MAKE_WINDOWS_PATH)
-    
 foreach(package ${packages})   
     set(dgen_impl ${CMAKE_BINARY_DIR}/cpp/qt_${package}/qt_${package}.pri)       
     break(package ${packages})