diff generator/CMakeLists.txt @ 403:8564ab82ea42

merge
author Eldar Insafutdinov
date Thu, 17 Mar 2011 19:46:11 +0000
parents a81c53f7b83b
children
line wrap: on
line diff
--- a/generator/CMakeLists.txt	Thu Mar 17 19:45:42 2011 +0000
+++ b/generator/CMakeLists.txt	Thu Mar 17 19:46:11 2011 +0000
@@ -200,6 +200,14 @@
 	OR NOT EXISTS ${jambi_inc})
     file(REMOVE ${dgen_build_conf})
     file(REMOVE ${jambi_inc})
+
+	# Explicitly include qglobal.h before all the »master includes« to make
+	# sure Q_CORE_EXPORT and other macros are already defined for all
+	# processed headers. Otherwise, the parser would choke on classes in files
+	# included before "qglobal.h" in <QtCore/QtCore> using one of these macros
+	# (e.g. QXmlStreamReader).
+	file(APPEND ${jambi_inc} "#include <${QT_QTCORE_INCLUDE_DIR}/qglobal.h>\n")
+
     file(APPEND ${dgen_build_conf} "<typesystem>\n")
     foreach(package_normal ${packages})
     	string(TOLOWER ${package_normal} package)
@@ -233,7 +241,7 @@
 set(d_inc_file_found 1)
 
 foreach(path ${QT_INCLUDES})
-    set(inc_paths_tmp ${path}${sep})
+    set(inc_paths_tmp ${path}${sep}${inc_paths_tmp})
 endforeach()
 set(inc_paths ${inc_paths}${sep}${inc_paths_tmp})