diff qt/CMakeLists.txt @ 248:7664de4a55e5

Fixed #23. QtD_QObjectEntity is not created dynamically for shell classes any more. Class initialization is now performed by static constructors. When wrapping QObjects returned from functions, their run-time types are now taken into account. QObjects are allocated on GC heap, a doubly-linked list is used to prevent them from been collected (arguably a better solution than allocating on C heap and adding GC ranges) Minor changes (including unnecessary).
author maxter
date Thu, 20 Aug 2009 14:47:17 +0000
parents e78566595089
children 37eed70de029
line wrap: on
line diff
--- a/qt/CMakeLists.txt	Fri Jul 31 11:05:22 2009 +0000
+++ b/qt/CMakeLists.txt	Thu Aug 20 14:47:17 2009 +0000
@@ -1,7 +1,7 @@
 project (qt_d D)
 
 set(QT_SRCS_D
-QtDObject.d
+QtdObject.d
 QGlobal.d
 
 core/QChildEvent.d