diff CMakeLists.txt @ 282:256ab6cb8e85

Signals look-up andNew syntax for connect. The old one will not work from now on. This will allow for the signals overload. Although changes are done for both D1 and D2 versions, D1 won't work because of compiler bugs. I am tired of waiting for fixes.
author eldar
date Fri, 16 Oct 2009 02:43:59 +0000
parents bcc498ccf334
children 3b79bd4298e8
line wrap: on
line diff
--- a/CMakeLists.txt	Sun Oct 11 05:23:41 2009 +0000
+++ b/CMakeLists.txt	Fri Oct 16 02:43:59 2009 +0000
@@ -49,9 +49,9 @@
 
 # Check D compiler version
 if(D_VERSION EQUAL "1")
-    if (D_FRONTEND LESS "041")
-	message(STATUS "Minimum required version of D compiler is 1.041 (or compiler based on this version)")
-    endif(D_FRONTEND LESS "041")
+    if (D_FRONTEND LESS "050")
+	message(STATUS "Minimum required version of D compiler is 1.050 (or compiler based on this version)")
+    endif(D_FRONTEND LESS "050")
     set(D_TARGET d1-tango CACHE INTERNAL "")   
 elseif(D_VERSION EQUAL "2")
     set(D_TARGET d2-phobos CACHE INTERNAL "")