diff runtime/CMakeLists.txt @ 1122:c614ef596a20

Fix imports copying for out-of-source build.
author Christian Kamm <kamm incasoftware de>
date Sun, 15 Mar 2009 23:04:58 +0100
parents bb57632d27ea
children 8403fec8c34c
line wrap: on
line diff
--- a/runtime/CMakeLists.txt	Sun Mar 15 16:57:44 2009 +0100
+++ b/runtime/CMakeLists.txt	Sun Mar 15 23:04:58 2009 +0100
@@ -30,9 +30,9 @@
 if(D_VERSION EQUAL 1)
 	# copy imports to runtime dir
 	set(LDC_IMPORTS)
-	macro(imports_file SRC)
-		get_filename_component(DEST ${SRC} NAME)
-		set(SRC  ${PROJECT_SOURCE_DIR}/${SRC})
+	macro(imports_file SRCARG)
+		get_filename_component(DEST ${SRCARG} NAME)
+		set(SRC  ${PROJECT_SOURCE_DIR}/${SRCARG})
 		set(DEST ${RUNTIME_DIR}/ldc/${DEST})
 		
 		list(APPEND LDC_IMPORTS ${DEST})