diff runtime/CMakeLists.txt @ 984:4c0df37d0421

Removing ldc.conf. (IMPORTANT: run 'cmake .' after pull) Added it to .hgignore. This gets rid of spurious differences caused by CMake regenerating it differently. Just run 'cmake .' to get it back in your local checkout.
author Frits van Bommel <fvbommel wxs.nl>
date Thu, 19 Feb 2009 13:50:05 +0100
parents 6e68054cfc20
children 616d7c90bb6a
line wrap: on
line diff
--- a/runtime/CMakeLists.txt	Thu Feb 19 11:01:34 2009 +0100
+++ b/runtime/CMakeLists.txt	Thu Feb 19 13:50:05 2009 +0100
@@ -114,7 +114,9 @@
 			${OUTPUT_O}
 			${OUTPUT_BC}
 		COMMAND ${LDC_LOC} -c -I${INCDIR} -output-bc ${INPUT_D} -of${OUTPUT_O} ${D_FLAGS} ${MOREFLAGS}
-		DEPENDS ${LDC_LOC} ${LDC_IMPORTS}
+		DEPENDS ${LDC_LOC}
+			${LDC_IMPORTS}
+			${PROJECT_BINARY_DIR}/../bin/${LDC_EXE}.conf
 	)
 endmacro(dc)
 
@@ -168,6 +170,7 @@
 			${CORE_BC}
 			${GC_BC}
 			${DCRT_BC}
+			${LDC_IMPORTS}
 	)
 	set(BCLIBS bclibs)
 endif(BUILD_BC_LIBS)