diff CMakeLists.txt @ 1107:015b1634b33f

Unquote ${LIBCONFIG_LDFLAGS} in target_link_libraries(). Without this change, LDC fails to link for me.
author Frits van Bommel <fvbommel wxs.nl>
date Thu, 12 Mar 2009 23:30:58 +0100
parents cdb7e1167803
children 123812e02bc8
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Mar 12 23:12:36 2009 +0100
+++ b/CMakeLists.txt	Thu Mar 12 23:30:58 2009 +0100
@@ -211,7 +211,7 @@
 )
 
 # LDFLAGS should actually be in target property LINK_FLAGS, but this works, and gets around linking problems
-target_link_libraries(${LDC_EXE} "${LLVM_LDFLAGS} ${LLVM_LIBS} ${LIBCONFIG_LDFLAGS}")
+target_link_libraries(${LDC_EXE} "${LLVM_LDFLAGS} ${LLVM_LIBS}" ${LIBCONFIG_LDFLAGS})
 if(WIN32)
 	target_link_libraries(${LDC_EXE} psapi)
 	set(CONF_INST_DIR bin)