sources/copas/PKGBUILD
author Anders Bergh <anders1@gmail.com>
Fri, 21 Dec 2007 22:32:34 +0000
changeset 12 faa5eb587542
parent 3 21b0b0f2b2cd
permissions -rw-r--r--
new versions

# Contributor: Anders Bergh <anders1@gmail.com>
pkgname=copas
pkgver=1.1.1
pkgrel=2
pkgdesc="Coroutine Oriented Portable Asynchronous Services for Lua"
arch=('i686' 'x86_64')
url="http://www.keplerproject.org/copas/"
license=('custom')
depends=('lua' 'luasocket')
source=('http://luaforge.net/frs/download.php/2559/copas-1.1.1.tar.gz'
        'LICENSE')
md5sums=('92e50bd367af81c7a50d349990f9ad97'
         '001e5e34c6e51b2c8501fd1c9dfad9fe')

build() {
  cd "$startdir/src/$pkgname-$pkgver"

  mkdir -p "$startdir/pkg/usr/share/lua/5.1/copas"
  cp src/copas/copas.lua "$startdir/pkg/usr/share/lua/5.1/copas"
  ln -s /usr/share/lua/5.1/copas/copas.lua "$startdir/pkg/usr/share/lua/copas.lua"

  mkdir -p "$startdir/pkg/usr/share/licenses/copas"
  cp $startdir/src/LICENSE "$startdir/pkg/usr/share/licenses/copas"
}

# vim:set ts=2 sw=2 et: