sources/copas/PKGBUILD
author Anders Bergh <anders1@gmail.com>
Mon, 17 Dec 2007 04:44:31 +0100
changeset 1 c42d991ddcdb
child 3 21b0b0f2b2cd
permissions -rw-r--r--
Add utils dir (sync scripts etc will go here) Add my AUR package sources Add some more things to .hgignore

# Contributor: Anders Bergh <anders1@gmail.com>
pkgname=copas
pkgver=1.1.1
pkgrel=1
pkgdesc="Coroutine Oriented Portable Asynchronous Services for Lua"
arch=('i686' 'x86_64')
url="http://www.keplerproject.org/copas/"
license=('custom')
depends=('lua' 'luasocket')
source=('http://luaforge.net/frs/download.php/2559/copas-1.1.1.tar.gz'
        'LICENSE')
md5sums=('92e50bd367af81c7a50d349990f9ad97'
         '001e5e34c6e51b2c8501fd1c9dfad9fe')

build() {
  cd "$startdir/src/$pkgname-$pkgver"

  mkdir -p "$startdir/pkg/usr/share/lua/5.1/copas"
  cp src/copas/copas.lua "$startdir/pkg/usr/share/lua/5.1/copas"
  ln -s /usr/share/lua/5.1/copas/copas.lua "$startdir/pkg/usr/share/lua/copas.lua"

  mkdir -p "$startdir/pkg/usr/share/licenses/copas"
  cp LICENSE "$startdir/pkg/usr/share/licenses/copas"
}

# vim:set ts=2 sw=2 et: