sources/libphobos/PKGBUILD
author Anders Bergh <anders1@gmail.com>
Fri, 21 Dec 2007 09:29:05 +0100
changeset 11 664cc1efa89d
parent 1 c42d991ddcdb
permissions -rw-r--r--
add gdc (but it's not really working) add llvm add dmd.conf to backup array in libphobos remove ./configure from luafilsystem

# Maintainer: Anders Bergh <anders1@gmail.com>
pkgname=libphobos
pkgver=1.024
pkgrel=2
pkgdesc="The Phobos standard library for the D programming language."
arch=('i686')
url="http://www.digitalmars.com/d/1.0/"
source=(http://ftp.digitalmars.com/dmd.$pkgver.zip dmd.conf)
md5sums=('249eb2a3b337ad4918444bb684219687'
         'e93f0ccb1e5c00cd222af5a9be3f599a')
depends=('d-dmd' 'dmd=1.024')
license=('custom')
conflicts=('libtango')

build() {
  # Copy the license
  mkdir -p $startdir/pkg/usr/share/licenses/libphobos || return 1
  cp $startdir/src/dmd/src/phobos/phoboslicense.txt $startdir/pkg/usr/share/licenses/libphobos/COPYING || return 1

  mkdir -p $startdir/pkg/usr/include/d || return 1
  mkdir -p $startdir/pkg/usr/lib || return 1
  mkdir -p $startdir/pkg/etc || return 1

  cd $startdir/src/dmd/src/phobos || return 1
  cp -Rf std $startdir/pkg/usr/include/d || return 1
  cp -Rf etc $startdir/pkg/usr/include/d || return 1
  cp -Rf internal $startdir/pkg/usr/include/d || return 1
  cp -f {crc32,object,gcstats}.d $startdir/pkg/usr/include/d || return 1

  make -f linux.mak libphobos.a || return 1
  install -m644 $startdir/src/dmd/lib/libphobos.a $startdir/pkg/usr/lib || return 1
  install -m664 $startdir/src/dmd.conf $startdir/pkg/etc || return 1
}